JPA在sqlserver2008下缺少sys.sequences的解决办法

目前在一个使用Spring Boot 2.0.2框架的工程里,使用jpa配合sqlserver2008,启动时直接报错”找不到sys.sequeces”对象。

经过跟踪代码,发现jpa对于数据库的版本识别出了问题。

定位到问题后,查找解决办法。查阅jpa的配置参数spring.jpa.database-platform能用来指定数据库版本。

在application.properties文件中,配置

spring.jpa.database-platform=org.hibernate.dialect.SQLServer2008Dialect

问题解决!